본문 바로가기

CodeUp

C언어) codeup 2623 [최대공약수 구하기]

2623 : 최대공약수 구하기 해결

시간 제한: 1 Sec  메모리 제한: 128 MB

 

문제 설명   

두 정수 aa, bb를 입력받아서, aa, bb의 최대공약수를 출력하시오.

입력

정수 aa, bb가 공백으로 구분되어 입력된다.(1<=a,b<=10,0001<=a,b<=10,000)

출력

aa, bb의 최대공약수를 출력한다.

입력 예시   예시 복사

64 128

출력 예시

64

1
2
3
4
5
6
7
8
9
10
11
12
13
14
#include <stdio.h>
 
int main(){
    int a, b;
    scanf("%d %d"&a, &b);
    int t;
    while (b){
        t = a%b;
        a = b;
        b = t;
    }
    printf("%d", a);
}
 
http://colorscripter.com/info#e" target="_blank" style="text-decoration:none;color:white">cs

유클리드 알고리즘을 이용하여 풀었다.


/*스크롤 인디케이터 시작*/ .header { position: absolute; top: 0; z-index: 1; width: 100%; background-color: #fff; } .progress-container { width: 100%; height: 4px; background: #f6f6f6; } .progress-bar { height: 4px; background: #6C6C6C; width: 0%; } /*스크롤 인디케이터 종료*/ /*왼쪽, 좌측 밑의 이미지 추가 시작*/ /*가로의 길이가 1510일때까지는 보여라*/ @media screen and (min-width:1500px) { .main_ad { display:visible; position: absolute; left: 0px; bottom: 80px; cursor: pointer; z-index: 11; } } /*가로의 길이가 1511일까지는 보이지 말아라*/ @media screen and (max-width:1510px) { .main_ad { display:none; position: absolute; left: 0px; bottom: 80px; cursor: pointer; z-index: 11; } } /*왼쪽, 좌측 밑의 이미지 추가 종료*/ /*이웃추가버튼 추가 시작*/ @media screen and (min-width:500px) { .add_adBanner { display:visible; } } @media screen and (max-width:510px) { .add_adBanner { display:none; } } .add_adBanner ul { position: absolute; left: 10px; bottom: 22px; cursor: pointer; z-index: 12; } .add_adBanner li { margin : 0 0 0 0; padding : 0 0 0 0; border : 0; float : left; } /*이웃추가버튼 추가 종료*/