본문 바로가기

CodeUp

C언어) CodeUp 1268 [n개의 수 중 짝수의 개수]

1268 : n개의 수 중 짝수의 개수 해결

시간 제한: 1 Sec  메모리 제한: 128 MB

제출: 13647  해결 문제 수: 10257

 

문제 설명

수의 개수 n이 주어지고, 그 다음 줄에 무작위로 n개의 자연수가 입력된다.

그 n개의 수 중에서 짝수의 개수를 출력하시오.

입력

n은 자연수, 그 다음 줄에 n개의 자연수들이 입력으로 들어온다.

출력

n개의 자연수들 중 짝수의 개수를 출력한다.

입력 예시   예시 복사

5 3 5 7 15 2

출력 예시

1

 

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
#include <stdio.h>
 
int main()
{
    int n, i, temp, count = 0;
    scanf("%d",&n);
    for(i = 0; i < n; i++)
    {
        scanf("%d"&temp);
        if (temp%2 == 0)
            count++;
    }
    printf("%d", count);
    return 0;
}
http://colorscripter.com/info#e" target="_blank" style="text-decoration:none;color:white">cs

/*스크롤 인디케이터 시작*/ .header { position: absolute; top: 0; z-index: 1; width: 100%; background-color: #fff; } .progress-container { width: 100%; height: 4px; background: #f6f6f6; } .progress-bar { height: 4px; background: #6C6C6C; width: 0%; } /*스크롤 인디케이터 종료*/ /*왼쪽, 좌측 밑의 이미지 추가 시작*/ /*가로의 길이가 1510일때까지는 보여라*/ @media screen and (min-width:1500px) { .main_ad { display:visible; position: absolute; left: 0px; bottom: 80px; cursor: pointer; z-index: 11; } } /*가로의 길이가 1511일까지는 보이지 말아라*/ @media screen and (max-width:1510px) { .main_ad { display:none; position: absolute; left: 0px; bottom: 80px; cursor: pointer; z-index: 11; } } /*왼쪽, 좌측 밑의 이미지 추가 종료*/ /*이웃추가버튼 추가 시작*/ @media screen and (min-width:500px) { .add_adBanner { display:visible; } } @media screen and (max-width:510px) { .add_adBanner { display:none; } } .add_adBanner ul { position: absolute; left: 10px; bottom: 22px; cursor: pointer; z-index: 12; } .add_adBanner li { margin : 0 0 0 0; padding : 0 0 0 0; border : 0; float : left; } /*이웃추가버튼 추가 종료*/