본문 바로가기

CodeUp

C언어) CodeUp 1418 [t를 찾아라]

문제 설명

어떤 문자열이 있을 때 문자 t의 위치를 모두 찾아 출력하시오.

입력

공백이 없는 문자열이 한 줄 입력된다.(10글자 이하)

출력

소문자 t의 위치를 공백으로 분리하여 모두 출력하시오.

입력 예시   예시 복사

test

출력 예시

1 4

1
2
3
4
5
6
7
8
9
10
11
12
#include <stdio.h>    
#include <string.h>
 
int main() {
    char a[100] = { 0 };
    scanf("%s", a);
    int len = strlen(a);
    for (int i = 0;i < len;i++) {
        if (a[i] == 't')
            printf("%d ", i + 1);
    }
}
http://colorscripter.com/info#e" target="_blank" style="text-decoration:none;color:white">cs

문제 풀이 방법 : 간단한 문제이다.


/*스크롤 인디케이터 시작*/ .header { position: absolute; top: 0; z-index: 1; width: 100%; background-color: #fff; } .progress-container { width: 100%; height: 4px; background: #f6f6f6; } .progress-bar { height: 4px; background: #6C6C6C; width: 0%; } /*스크롤 인디케이터 종료*/ /*왼쪽, 좌측 밑의 이미지 추가 시작*/ /*가로의 길이가 1510일때까지는 보여라*/ @media screen and (min-width:1500px) { .main_ad { display:visible; position: absolute; left: 0px; bottom: 80px; cursor: pointer; z-index: 11; } } /*가로의 길이가 1511일까지는 보이지 말아라*/ @media screen and (max-width:1510px) { .main_ad { display:none; position: absolute; left: 0px; bottom: 80px; cursor: pointer; z-index: 11; } } /*왼쪽, 좌측 밑의 이미지 추가 종료*/ /*이웃추가버튼 추가 시작*/ @media screen and (min-width:500px) { .add_adBanner { display:visible; } } @media screen and (max-width:510px) { .add_adBanner { display:none; } } .add_adBanner ul { position: absolute; left: 10px; bottom: 22px; cursor: pointer; z-index: 12; } .add_adBanner li { margin : 0 0 0 0; padding : 0 0 0 0; border : 0; float : left; } /*이웃추가버튼 추가 종료*/